Howdy! - Suzuki Z400 Forum : Z400 Forums
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 05-16-2017, 09:48 AM Thread Starter
:::Rookie Rider:::
 
Join Date: May 2017
Posts: 1
Howdy!

Hey everyone I'm new to the forum and to my 07 Ltz 400 that I just purchased!
Joined to get maintenance tips and help if I ever have issues.
Ej25.Life is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-16-2017, 10:48 AM
:::Post Whore:::
 
amcf18's Avatar
 
Join Date: Apr 2010
Location: Quartzsite Az,/ Picton, On
Posts: 2,825
Garage
Welcome! Where are you located?

2007 LTZ 400.. 94mm J&E piston, +4mm hotrods crank, 536webb cams,wiseco valves, 39mm fcr, tokyo mods throttle spring, honda thumb throttle,spring removed. yoshimura full exhaust, honda 400ex intake tube, no air box
amcf18 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki Z400 Forum : Z400 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome