new memeber - Suzuki Z400 Forum : Z400 Forums
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 06-13-2019, 09:52 AM Thread Starter
:::Rookie Rider:::
 
Join Date: Jun 2019
Posts: 3
Talking new memeber

coming from mass
lfortes is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-13-2019, 09:55 AM Thread Starter
:::Rookie Rider:::
 
Join Date: Jun 2019
Posts: 3
Unhappy new member from massachusetts

new member from Massachusetts having trouble with my ltz 400 started when I did the screw driver trick to the relay then the next day I tried to do it asnd it just bogs a little is it because I left the battery on there overnight when I try to start it it just clicks from the relay but how else can I test the relay
lfortes is offline  
post #3 of 3 (permalink) Old 07-04-2019, 08:17 AM
:::Rookie Rider:::
 
alaxjordan0's Avatar
 
Join Date: Jul 2019
Location: USA
Posts: 15
Nice to see you here, Matt. A newbie here too.
alaxjordan0 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki Z400 Forum : Z400 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome