Hi I'm doug24...I have a 2006 Suzuki quad sport...Z400 - Suzuki Z400 Forum : Z400 Forums
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 07-29-2019, 11:10 PM Thread Starter
:::Rookie Rider:::
 
Douglas Marquard's Avatar
 
Join Date: Jul 2019
Posts: 2
Hi I'm doug24...I have a 2006 Suzuki quad sport...Z400

So....I recently just got my bike goin...a month ago...n lately as a couple days now....been popping around...gets hot...my pipe comes out of the cylinder...gets red...n I just recently put new valves in it...got everything in time...and torqued down to the rite specs...and now wont start...turns over but acts like it's not getting gas....just took carburetor off...and cleaning it now...any suggestions? ...would be greatly appreciated.
Douglas Marquard is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-30-2019, 01:32 AM
:::Official Spammer:::
 
jetmech25's Avatar
 
Join Date: Apr 2012
Location: San Diego, CA
Posts: 3,974
Welcome! Thatís where I would start, cleaning the carb out.

'05 Z
94mm bbk, +4 stroker, Hot Cams, Vertex piston, FMF Power Bomb header and Power Core can, KW black diamond valves/dual springs, FCR39, K&N, Elka long-travel LT fronts and rear, Houser +3, +3/4 LT A-arms, American Star pro xs chromoly tie rods, Dyna non-programable, Tusk +3 axle.
jetmech25 is online now  
post #3 of 3 (permalink) Old 09-13-2019, 04:51 AM
:::Rookie Rider:::
 
Join Date: Aug 2019
Posts: 5
Welcome here!
konradsc is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki Z400 Forum : Z400 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome