Annoying problem tuning fcr 39 Ltz beast - Suzuki Z400 Forum : Z400 Forums
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 05-30-2019, 09:43 AM Thread Starter
:::Rookie Rider:::
 
The Tru's Avatar
 
Join Date: Jul 2017
Location: SXM-Best Island
Posts: 24
Angry Annoying problem tuning fcr 39 Ltz beast

I've been trying to properly jet and tune my bike for 5 months, I even took it to a "quad specialist" to jet but he couldn't figure it out.
I've looked on the Jetting database but couldn't quite find someone with my a similar setup:

I have an 05' ltz 400
my current jetting is:

Carb Type: FCR 39

Main Jet: 172 Keihin

Pilot Jet: 45 Keihin

Fuel Screw: 2 and 3/4 out

Needle: Stock Ngnr needle, but I have the ncvq needle waiting to be put in

Airbox: K&N open lid

Pipe: DMC Afterburner 4 - Full exhaust

Engine Displacement: 434, Ferrea valves and spring and ported head

Cams: New style hotcams

CDI: Dynatek CDI
Altitude: Sea level

I Backfire a lot after leaving go of the throttle and during deceleration as well.

I'm also leaking gas out of the overflow when the quad is in motion, but the float looks fine to me

Can someone please help, would be greatly apreciated

05' Ltz 400
BBK 434
New style hot cams
Ported head
FCR 39
K&N Air filter
Tusk nerf bars
The Tru is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-30-2019, 11:54 AM
:::Official Spammer:::
 
jetmech25's Avatar
 
Join Date: Apr 2012
Location: San Diego, CA
Posts: 3,846
Have you replaced the float needle and seat? Thatís the cause of your leak.

Put that ncvq needle in on the 3rd or 4th clip. I use the Tusk extended mixture screw for on-the-fly adjustments. Just write down ďmoved from 2 turns out to 2 and 1/4 outĒ or something like that with each adjustment so you know what to do if it gets better or worse. Your main might be a little large, if nothing else works.

'05 Z
94mm bbk, +4 stroker, Hot Cams, Vertex piston, FMF Power Bomb header and Power Core can, KW black diamond valves/dual springs, FCR39, K&N, Elka long-travel LT fronts and rear, Houser +3, +3/4 LT A-arms, American Star pro xs chromoly tie rods, Dyna non-programable, Tusk +3 axle.
jetmech25 is offline  
post #3 of 4 (permalink) Old 06-01-2019, 02:14 PM Thread Starter
:::Rookie Rider:::
 
The Tru's Avatar
 
Join Date: Jul 2017
Location: SXM-Best Island
Posts: 24
No, I haven't replaced it, is there a way to modify it to stop the leak? what main and pilot do you recommend?

05' Ltz 400
BBK 434
New style hot cams
Ported head
FCR 39
K&N Air filter
Tusk nerf bars
The Tru is offline  
 
post #4 of 4 (permalink) Old 06-01-2019, 11:53 PM
:::Official Spammer:::
 
jetmech25's Avatar
 
Join Date: Apr 2012
Location: San Diego, CA
Posts: 3,846
I have no idea how it is accelerating, but you can try a 170 main and see if it pulls better or worse in the higher gears.

Youíll have to pull the float out and take a look. It might just have some dirt stuck in there holding it open, but the seat is often dry rotted and cracked. Itís basically an o-ring, they go bad over time, especially if itís left without fuel in it for awhile.

'05 Z
94mm bbk, +4 stroker, Hot Cams, Vertex piston, FMF Power Bomb header and Power Core can, KW black diamond valves/dual springs, FCR39, K&N, Elka long-travel LT fronts and rear, Houser +3, +3/4 LT A-arms, American Star pro xs chromoly tie rods, Dyna non-programable, Tusk +3 axle.
jetmech25 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki Z400 Forum : Z400 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome