Kibblewhite valve cotters - Suzuki Z400 Forum : Z400 Forums
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 07-05-2019, 01:27 PM Thread Starter
:::Rookie Rider:::
 
Join Date: Feb 2019
Posts: 5
Kibblewhite valve cotters

Hi

I just received a set of Kibblewhite valves, springs and valve Guides. I thought that the kit includes the valve cotters, but no.
Could I use the OEM ones or should I use specific Kibblewhite valve cotters? I asked to the seller and he says that i could reuse my OEM ones.
I'm just looking for a second opinion.

Thanks!
Luis Galindo is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 07-05-2019, 01:29 PM Thread Starter
:::Rookie Rider:::
 
Join Date: Feb 2019
Posts: 5
It is this specific kit


Luis Galindo is offline  
post #3 of 5 (permalink) Old 07-05-2019, 05:40 PM
:::Official Spammer:::
 
jetmech25's Avatar
 
Join Date: Apr 2012
Location: San Diego, CA
Posts: 3,941
I reused my factory keepers with KW valves. No problems.

'05 Z
94mm bbk, +4 stroker, Hot Cams, Vertex piston, FMF Power Bomb header and Power Core can, KW black diamond valves/dual springs, FCR39, K&N, Elka long-travel LT fronts and rear, Houser +3, +3/4 LT A-arms, American Star pro xs chromoly tie rods, Dyna non-programable, Tusk +3 axle.
jetmech25 is offline  
post #4 of 5 (permalink) Old 07-06-2019, 12:16 AM
:::Official Spammer:::
 
amcf18's Avatar
 
Join Date: Apr 2010
Location: Quartzsite Az,/ Picton, On
Posts: 3,321
Garage
Quote:
I reused my factory keepers with KW valves. No problems.

Same here...

2007 LTZ 400.. 94mm J&E piston, +4mm hotrods crank, 536webb cams,wiseco valves, 39mm fcr, tokyo mods throttle spring, honda thumb throttle,spring removed. yoshimura full exhaust, honda 400ex intake tube, no air box
amcf18 is offline  
post #5 of 5 (permalink) Old 07-06-2019, 05:47 AM Thread Starter
:::Rookie Rider:::
 
Join Date: Feb 2019
Posts: 5
Thank's! I will reuse the OEM Keepers.
Luis Galindo is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki Z400 Forum : Z400 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome