Eiger question - Suzuki Z400 Forum : Z400 Forums
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 04-19-2015, 01:31 PM Thread Starter
:::Rookie Rider:::
 
Join Date: Apr 2015
Posts: 3
Eiger question

I have an 04 Eiger semi auto 4x4. Bought it used. It has good compression and spark, put a brand new OEM carb and manifold on it, new spark plug and did the Raptor 660 petcock retrofit and capped off the carb. So.....here is the question: I turn the fuel on, turn choke on and it fires right up and idles great. I wait 1-2 minutes and go to turn choke off and it stalls. I then leave the choke off and it fires right up and runs great all day and starts right up without needing choked the rest of the day. So why does it die when I turn the choke off?!!!
Eljefe is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki Z400 Forum : Z400 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome