03 Lt A50 followed me home - Suzuki Z400 Forum : Z400 Forums
 
LinkBack Thread Tools
post #1 of 10 (permalink) Old 10-24-2019, 01:14 AM Thread Starter
:::Mini LT50 Rider:::
 
Join Date: Dec 2016
Location: Kansas City MO
Posts: 82
03 Lt A50 followed me home

Well another orphan came to the garage. You will have to wait to see the plastics





My kids are going to be so stoked on Xmas (If I can get the thing running lol!) Or if I can wait that long to show them!



Where to start with the hoopty.



The worst thing, this is what I found when opening the carb up


Tore it down and ultra sonic it, but still a little hairy...really tempted to try the $30 china carb as im also missing the air filter assembly and they come with it. Good idea?




This is the gas cap, completely frazzled. Are there any other caps that are compatible? A new cap is $45!


Petcock is junk, I have an extra Raptor 660 petcock.....is that OK to use it and block off the vacuum port on the carb? (nice screw adjustment knob lol)



The rear brake cable line is chazzled at the handlebars ....thinking about just ditching the rear brake as its expensive to buy the line.




Any issue removing this thing going into the pull start? (if I remove rear brake)






Any help or advice is greatly appreciated!
QuadSnort is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 10-25-2019, 12:57 AM Thread Starter
:::Mini LT50 Rider:::
 
Join Date: Dec 2016
Location: Kansas City MO
Posts: 82
Update:


Got it all back together tonight. Thing wouldn't start or sputter or nothin.



Key on
Safety plug in
Little black parking brake button pushed in (if it has to be I dont know)
Plug is in good shape and is wet
Getting great spark
Choke on works fine


Pull pull pull nothin.


Edit: Found a video online of a guy with the same issue of air blowing out of the pull start hole. His issue was a seal behind the flywheel around the shaft, but he didnt give alot of explanation. Is this the crank seal? Looks like ill need a special flywheel puller. Will a JR50 ebay puller work on this too? Any help is greatly appreciated!



Last edited by QuadSnort; 10-25-2019 at 10:40 PM.
QuadSnort is offline  
post #3 of 10 (permalink) Old 10-25-2019, 10:25 PM Thread Starter
:::Mini LT50 Rider:::
 
Join Date: Dec 2016
Location: Kansas City MO
Posts: 82
Ok it is that seal behind there.



I got to here. Can someone tell me of a cheap puller to get this off? Does the ebay JR50 puller work?



Last edited by QuadSnort; 10-25-2019 at 10:41 PM.
QuadSnort is offline  
 
post #4 of 10 (permalink) Old 10-26-2019, 01:04 AM
:::Official Spammer:::
 
jetmech25's Avatar
 
Join Date: Apr 2012
Location: San Diego, CA
Posts: 4,047
No idea. I can be somewhat useful on Z400s, but know nothing about your machine.

'05 Z
94mm bbk, +4 stroker, Hot Cams, Vertex piston, FMF Power Bomb header and Power Core can, KW black diamond valves/dual springs, FCR39, K&N, Elka long-travel LT fronts and rear, Houser +3, +3/4 LT A-arms, American Star pro xs chromoly tie rods, Dyna non-programable, Tusk +3 axle.
jetmech25 is offline  
post #5 of 10 (permalink) Old 10-26-2019, 01:49 AM Thread Starter
:::Mini LT50 Rider:::
 
Join Date: Dec 2016
Location: Kansas City MO
Posts: 82
Quote:
Originally Posted by jetmech25 View Post
No idea. I can be somewhat useful on Z400s, but know nothing about your machine.

Bro you are a wizard with the Z400 and I thank you. Cant expect you to know everything
Snagged a brand new Suzuki OEM carb for $50, gonna fab up some kind of filter mount.



Hopefully harbor freight has a flywheel puller that is compatible, so I can get eyes on the seal. I see they have a kit.
QuadSnort is offline  
post #6 of 10 (permalink) Old 10-27-2019, 12:47 AM Thread Starter
:::Mini LT50 Rider:::
 
Join Date: Dec 2016
Location: Kansas City MO
Posts: 82
Update:

Harbor Freight wheel puller worked great! Sure enough, oil seal just sitting right there out of place in perfect shape. Snapped it back in and the thing fired right up.

Unfortunately it does sound "rattley" in the head so I assume it needs rebuilt.

How does this feebay top end rebuild kit look here? Any tips on installation is greatly appreciated!


Last edited by QuadSnort; 10-27-2019 at 12:51 AM.
QuadSnort is offline  
post #7 of 10 (permalink) Old 10-27-2019, 11:59 AM
:::Official Spammer:::
 
jetmech25's Avatar
 
Join Date: Apr 2012
Location: San Diego, CA
Posts: 4,047
Wow, so cheap! Just remember to coat the piston wrist pin in oil when installing it, gap the rings by filing them to spec, and position them like the manual says (with the gaps in opposing clock positions). Everything else is fairly bolt-on.

'05 Z
94mm bbk, +4 stroker, Hot Cams, Vertex piston, FMF Power Bomb header and Power Core can, KW black diamond valves/dual springs, FCR39, K&N, Elka long-travel LT fronts and rear, Houser +3, +3/4 LT A-arms, American Star pro xs chromoly tie rods, Dyna non-programable, Tusk +3 axle.
jetmech25 is offline  
post #8 of 10 (permalink) Old 11-04-2019, 12:27 AM Thread Starter
:::Mini LT50 Rider:::
 
Join Date: Dec 2016
Location: Kansas City MO
Posts: 82
^ Good lookin out bro! That is good info for all.

Finally some progress. In anticipation of the parts arrival tomorrow, I got the head tore off.

Also lucked out on a brand new factory carb for $50. Slapped a new chain on it as well.



QuadSnort is offline  
post #9 of 10 (permalink) Old 11-04-2019, 07:22 PM Thread Starter
:::Mini LT50 Rider:::
 
Join Date: Dec 2016
Location: Kansas City MO
Posts: 82
Got the new top end back together today, fired right up. Didnt take pics, it was so easy. So stoked!
Still have to figure out that rear brake line. It also needs a seat bracket. May have to fab up foot boards.

QuadSnort is offline  
post #10 of 10 (permalink) Old 11-04-2019, 09:17 PM
:::Official Spammer:::
 
jetmech25's Avatar
 
Join Date: Apr 2012
Location: San Diego, CA
Posts: 4,047
Sweet! Definitely need nerf bars with ankle guards. Donít want little feet getting into the tire!

'05 Z
94mm bbk, +4 stroker, Hot Cams, Vertex piston, FMF Power Bomb header and Power Core can, KW black diamond valves/dual springs, FCR39, K&N, Elka long-travel LT fronts and rear, Houser +3, +3/4 LT A-arms, American Star pro xs chromoly tie rods, Dyna non-programable, Tusk +3 axle.
jetmech25 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki Z400 Forum : Z400 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome