Suzuki Z400 Forum : Z400 Forums - Search Results
Advanced Search
Showing results 1 to 7 of 7
Search took 0.01 seconds.
Search: Posts Made By: alecdroxx
Forum: New Member Introductions   02-15-2019, 02:33 PM
Replies: 13
Views: 526
Posted By alecdroxx
i rebulit the carb so i dont think it is that,...

i rebulit the carb so i dont think it is that, ill try a new petcock
Forum: New Member Introductions   02-13-2019, 02:46 PM
Replies: 13
Views: 526
Posted By alecdroxx
ok guys, i made a quick temporary fix until i get...

ok guys, i made a quick temporary fix until i get the money to buy a jet kit, there are some holes in the airbox and i blocked off most of them with duct tape and the thing is running beautifully, it...
Forum: New Member Introductions   02-05-2019, 02:37 PM
Replies: 13
Views: 526
Posted By alecdroxx
i have size 130 and 80 jets, i belive those are...

i have size 130 and 80 jets, i belive those are stock
Forum: New Member Introductions   02-01-2019, 03:06 PM
Replies: 13
Views: 526
Posted By alecdroxx
so i think maybe the guy before me may have put a...

so i think maybe the guy before me may have put a bigger jet in it already. it backfires after rev in neutral and still the sputtering problem, i have to rebuild my carb anyway and im going to try...
Forum: New Member Introductions   02-01-2019, 02:45 PM
Replies: 13
Views: 526
Posted By alecdroxx
and yes, it is stock filter and stock exhaust up...

and yes, it is stock filter and stock exhaust up to the hmf slip on on the back
Forum: New Member Introductions   02-01-2019, 02:44 PM
Replies: 13
Views: 526
Posted By alecdroxx
i tired it one night with the cover for the...

i tired it one night with the cover for the airbox off, it ran like total crap it would not let me rev after first gear and would barely moove, there are little black plugs on the cover i removed - 6...
Forum: New Member Introductions   01-25-2019, 03:09 PM
Replies: 13
Views: 526
Posted By alecdroxx
2003 suzuki ltz 400 problems

the quad runs great and idles good in 1st and second ear, but once i go full throttle in 3rd 4th and 5th gear it starts to bog down and bang until i let off the gas, if i gently ease into the gas it...
Showing results 1 to 7 of 7

 
Forum Jump
 
For the best viewing experience please update your browser to Google Chrome