Suzuki Central Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
When i put it on pri the gas flows out of the bigger line if looking at it your left... Thats the only line the gas come out...when i put it on no flow or res...any suggestions
 

·
Registered
Joined
·
1,410 Posts
we really need a sticky on this...

well, the stock petcock works off of vacuum in the "on" and "res" positions.. On the stock petcock there should be 2 lines that go from it to the carb, 1 is the fuel line, and the other is a vacuum line that operates the petcock in the "on" and "res" positions.. check to make sure the vacuum line going from the upper side of the carburetor (kind of above the fuel line) is connected to both the carb and the petcock..
If they are connected and you still aren't getting any fuel flow, your petcock might be clogged or broken.. If I were you, I would just buy the petcock off a Raptor 660 (thats what I did) and you will be trouble free forever.. just make sure you block off the vacuum connection on the carburetor where the old petcock connected. You can get a Raptor petcock off ebay for about $30 or so...
 

·
Registered
Joined
·
1,410 Posts
They guy I bought mine from was selling it for $30 or best offer with a $5 shipping charge.. I did a best offer of $25 bucks and it accepted it right away, I probably could have gotten it for a few bucks cheaper..
 

·
Registered
Joined
·
1,410 Posts
yeah, if it doesn't bother you, you can just leave it on prime.. make sure that the vacuum port on the carb that connects to the petcock is blocked off though if there is no hose on it going to the valve.. you wouldn't want a vacuum leak.
 

·
Registered
Joined
·
9 Posts
So I'm trying to switch my petcock valve to a raptor 660 one. But when I put it on the tank, the bolts just turn and don't tighten down.

How did I do something wrong pulling and putting in 2 bolts?!
 

·
Administrator
Joined
·
12,453 Posts
So I'm trying to switch my petcock valve to a raptor 660 one. But when I put it on the tank, the bolts just turn and don't tighten down.

How did I do something wrong pulling and putting in 2 bolts?!
It was probably stripped when you bought it. Search stripped petcock bolts and see if anything comes up.
 

·
Administrator
Joined
·
12,453 Posts
spize you are a genius. Already ordered a used tank, but I found this http://www.suzukicentral.com/forums...82-anybody-ever-fix-stripped-petcock-nut.html which is the exact problem I'm having.

To the garage to tinker with stuff!
You should start a thread titled "Spize is a genius". This is nothing new for me but I really think it would be good to let everybody know :lol

It just comes down to searching. The site has been around over 10 years. Almost everything has come up.
 

·
Registered
Joined
·
9 Posts
I dunno if I would go as far as creating a whole new thread for you. Lol I searched Petcock and read tons of thread, but never stumbled across that one I needed.
 
1 - 17 of 17 Posts
Top