Suzuki Central Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I was riding yesterday and came to a complete stop and stalled my bike and haven't been able to start it since. It will turn over and sounds strong but no fire. Tried to pull start it, and it never fired, sounds like its not getting spark can someone help me Please! I would like to start with the obvious first without tearing it all down. took the spark out and grounded it, but no spark was there. I was also told that when i traded it that i would have to buy a Cid box cause it has a BIG GUN on it. Help!:angryfire:
 

·
Registered
Joined
·
95 Posts
Does the motor turn over? Might be timing chain, I had that problem once..it could also be the cdi box. But the motor would still turn over. Try the simple checks first as in checking the fuses, new plug, and we'll charged battery..
 

·
Premium Member
Joined
·
4,890 Posts
I was riding yesterday and came to a complete stop and stalled my bike and haven't been able to start it since. It will turn over and sounds strong but no fire. Tried to pull start it, and it never fired, sounds like its not getting spark can someone help me Please! I would like to start with the obvious first without tearing it all down. took the spark out and grounded it, but no spark was there. I was also told that when i traded it that i would have to buy a Cid box cause it has a BIG GUN on it. Help!:angryfire:
Cant say i have any confidence in that cdi.maybe try a stock cdi
 

·
Registered
Joined
·
1,536 Posts
Ive had that happen and the inside of my spark plug wire came apart.
 

·
Super Moderator
Joined
·
4,638 Posts
Well, at least you have an idea with the lack of spark. Change the plug. Check all the connectors, particularly any that have tight wiring. Put a meter on the blob kill switch to make sure it has contact. After that, look into the coil or CDI.
 

·
Premium Member
Joined
·
4,890 Posts
it could even be a sheared flywheel key. granted that does not happen very often but it can happen
 

·
Registered
Joined
·
17 Posts
Well, at least you have an idea with the lack of spark. Change the plug. Check all the connectors, particularly any that have tight wiring. Put a meter on the blob kill switch to make sure it has contact. After that, look into the coil or CDI.
Hey jet. I finally got mine back together not blowing the fuse anymore but now having this same issue. Won't start. I can jump across the starter and it will try to. I checked spark plug. It was wet changed it out with new one. No spark. When you say check the coil what exactly are we talking about?
 

·
Super Moderator
Joined
·
4,638 Posts
There are primary and secondary resistance checks in the manual that have minimum and maximum limits. If they’re outside of those limits, it’s bad. You’ll need the specs and a multimeter.
 

·
Super Moderator
Joined
·
4,638 Posts
These specs are for carb models, not sure if FI models are the same.
 
1 - 9 of 9 Posts
Top