Suzuki Central Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
I have a +4 stroker crank and a 94mm vertex piston,just got it all back together and it sounds like my valves are hitting the piston,hot rods says you can use any piston with this crank but now I wonder, Kevin
 

·
Super Moderator
Joined
·
4,872 Posts
I had that exact setup and had no problems. It wasn’t a stroker piston, just a standard piston that came in a Cylinder Works kit.
The stroker piston isn’t required unless you go to a +5.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #3
But it sounds like it's knocking,I used a drz base gasket do you think I just need higher octane?
 

·
Super Moderator
Joined
·
3,590 Posts
What octane are you running? Did you put a high compression piston in it? Mine would just ping slightly under heavy load off idle on 91. Ran perfect other than that. 12.5 to 1 piston. I put the regular gasket back in, to get rid of that slight ping and help it start easier.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #5
What octane are you running? Did you put a high compression piston in it? Mine would just ping slightly under heavy load off idle on 91. Ran perfect other than that. 12.5 to 1 piston. I put the regular gasket back in, to get rid of that slight ping and help it start easier.
11.3.1 comp 93 and octane booster,and it's not just a ping it is a knock, going back to ltz base gasket
 

·
Super Moderator
Joined
·
3,590 Posts
What cam do you have?
 

·
Registered
Joined
·
28 Posts
Discussion Starter #7
Stage 2 hot cams
 
1 - 7 of 7 Posts
Top