Suzuki Central Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
449 Posts
Discussion Starter #1

·
Administrator
Joined
·
12,447 Posts
Looks bada$$.
I think about replacing the "k&N' knockoff filter though.
 

·
Registered
Joined
·
973 Posts
Looks mean, good find ?
 

·
Registered
Joined
·
449 Posts
Discussion Starter #4
Ya I need to get a foam filter, but at least there's two pre filters on it. Maybe it'll be safe till I switch over to foam

So I rode this thing a little today an it seems like it gets hot easy. Header bout takes the hair off your leg an fan runs a lot. Maybe it's normal just kinda worried me. It was 95 today but how do you know if it's running lean or not with this fuel injection
 

·
Registered
Joined
·
2,225 Posts
bak in da game yo
 

·
::3 Pump Chump!::
Joined
·
3,013 Posts
Ya I need to get a foam filter, but at least there's two pre filters on it. Maybe it'll be safe till I switch over to foam

So I rode this thing a little today an it seems like it gets hot easy. Header bout takes the hair off your leg an fan runs a lot. Maybe it's normal just kinda worried me. It was 95 today but how do you know if it's running lean or not with this fuel injection
its normal.
 

·
Registered
Joined
·
449 Posts
Discussion Starter #7
Actually rode it a while today man I love this thing. Just hard to keep that black clean





Anybody know what this is supposed to go to?
 

·
Registered
Joined
·
511 Posts
would that plug in to your brake lever, for your tail light? I don't know just a guess.

Nice bike!
 

·
Registered
Joined
·
449 Posts
Discussion Starter #9
Well I first thought head light since it's been removed (and tail light) but I don't know why it's clipped to the fan so I don't know
 

·
Registered
Joined
·
1,771 Posts
Looks nice, hang tight one of the ltr guys ( Tucker,Tyler,Kevin,Scott) will chime in and tell you where that plug goes. Lol
 

·
Registered
Joined
·
449 Posts
Discussion Starter #11
Well have bad news. Really bummed out ain't had this thing long at all. Rode out to my buddies house an he rode it around the house an he said it starting knocking an lost power so he cut it off. Checked oil an it wasn't touching the stick so I hauled it home drained the oil an it had over a qt in the tank. So I filled it up an tried to start it. But the starter won't turn the motor over. I can turn it with a wrench though. Pulled the filter an cut it open an had some metal shavings



That's the worst of it in the pic. So what you guys think? Time to split the cases?
 
1 - 11 of 11 Posts
Top