Suzuki Central Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey guys

Story time. Bought an 03 ltz this spring, was riding it one day and the chain came off. Ended up cracking the case where the clutch shaft goes into the engine. Got a local guy to tig weld it and I reinstalled the clutch shaft bearing, washer, gasket. It was kind of tore apart at the time so I took the carb apart and gave it a good clean. Now it seems to be idling rough, kind of sounds like it's bogging out. Also when I'm downshifting, it'll stall out now and again. Mostly when going from 2nd to 1st.

Soo I ended up rebuilding the carb. No luck. Also installed a new plug and air filter. Flippin thing still isn't running well. My brother has the same quad so I tried his fuel tank, carburetor and ignition coil on mine. Still no luck. I sprayed some wd-40 on the air hoses while it was idling to look for a leak, no change in rpm's at all. Also checked the valves and timing chain, everythings in spec.

Anyone have any ideas? Just about ready to take it to a shop and have someone look at it.
 

·
Super Moderator
Joined
·
4,502 Posts
Still sounds like a carb thing to me. Sometimes cleaning just knocks dirt loose to go further down a passage and clog up again. I’d at least go through it again.
 

·
Super Moderator
Joined
·
3,390 Posts
How many turns out on the fuel screw are you? Does it help if you turn it out?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Haha, well, I'm a dummy. I had the choke position wrong on the thing. Turns out the choke lever all the way down means its on. Was running on a full choke. Facepalmed pretty hard at that one
 
1 - 4 of 4 Posts
Top