Suzuki Central Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Man I cant get this ltz400 to run right. It's a fresh rebuild and everything valve wise is in spec. I had a stock mikuni carb on it and it ran decent but it seemed like it was running out of fuel when youd ride it down the road. Once the bowl was empty it would start popping and leaning out. So I buy a brand new carburetor for it and I swapped my jets and I fired it up and this thing is lean lean lean. Pipe is glowing red instantly. I tried to tune it but nothing. I cannot figure out why I'm having so many problems with this quad lol
 

·
Super Moderator
Joined
·
4,682 Posts
Stock petcock? When they start going bad, the fuel can be restricted enough that the carb uses it faster than supplied.
 
  • Like
Reactions: CFM

·
Super Moderator
Joined
·
3,463 Posts
Gas cap or petcock are the usual suspects. Gotta check for a flow of clean fuel.
 
  • Like
Reactions: CFM

·
Super Moderator
Joined
·
4,682 Posts
I don’t know what sizes of jets you have in it or where in the rpm range it’s having issues, but it sounds like you need to go up on the jet sizes.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #6
I didnt check the jets. But it's a bone stocks bike. Nothing has been done to it besides a rebuild and I didnt bore it over or anything. I found my vaccum for my petcock was partially clogged so I cleaned it thoroughly and it pumps fuel great now but now it runs like crap the entire time you ride it lol
 

·
Registered
Joined
·
22 Posts
Discussion Starter #8
Okay my exhaust is shot. I discovered this afternoon that all of the packing is blown out. And its leaking around the muffler will this cause any issues with it running bad? I didnt know if it needed back pressure to run properly or if the gaping hole was causing it to run lean
 

·
Super Moderator
Joined
·
4,682 Posts
It does have some effect, but not sure how much. If you’re planning on replacing the exhaust, I would do that first. If not, try putting a bigger main in it.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #10
Well I had another muffler laying around and i swapped them out to no avail. Ever since I got this quad I've had nothing but problems lmao
 

·
Super Moderator
Joined
·
4,682 Posts
The choke isn’t an actual choke, but rather an enrichment circuit that gives it more fuel. It also makes a great troubleshooting tool when tuning to tell you if you’re lean or rich. So, it sounds like either the jets are partially clogged or it’s jetted too lean. I replace my jets every year because it’s easier than cleaning the varnish and corrosion off of them after setting for several months with fuel in it. If you just did a rebuild, I’m guessing it was out of commission for a bit and sat for awhile. This way I’m certain they are spotless all year, well worth the $12 it costs.
From the factory, these carbs come jetted very lean to help pass emissions. Anything you do to improve airflow, like removing the airbox lid or snorkle, swapping to a K&N or uni-style air filter, aftermarket exhaust, etc will probably require at least a bigger pilot jet if not going larger on both the pilot and main jets.
If your petcock was partially clogged, chances are some of that dirt went downstream after you put it back together. This is why it usually takes several carb cleanings to get all of the dirt out. I would check your main jet again, or just replace it.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #14
I took the carb apart one more time to make sure that wasnt the issue and I found some gunk built up under the float needle peice. And I cleaned it all out really good. And I threw the carb back on and it still runs like crap. So I'm starting to lean towards a Ignition issue or something
 

·
Registered
Joined
·
22 Posts
Discussion Starter #15
I bumped the main jet up to 146 instead of 140 and it runs better but it still has a stutter when accelerating
 

·
Super Moderator
Joined
·
4,682 Posts
Should be more like a 155. 140 is tiny. Does it have an adjustable needle with a moveable clip? Or the stock needle that just has a “nail” head on it?
 

·
Registered
Joined
·
22 Posts
Discussion Starter #17
Well I have more jets so i can bump it up to 155. What about the pilot jet? I think mine has a 60 in it I'll check again but I think that's what's in it. But it's still sputtering under hard acceleration
 

·
Registered
Joined
·
22 Posts
Discussion Starter #19
Alright I finally fixed it. Thank you for the 155 main jet suggestion. It worked phenomenally. I also took my petcock apart to see my passages were completely packed full of junk. I took the diaphragm off and I sprayed air in all of the passages and so much junk came out. This thing rips now thank you for your help
 

·
Super Moderator
Joined
·
4,682 Posts
Anytime! I would still upgrade it, but that’s just me. I like having an off position.
 
  • Like
Reactions: Jerichobaker
1 - 20 of 24 Posts
Top