Suzuki Central Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
138 Posts
Discussion Starter #1

·
Registered
Joined
·
425 Posts
If your gonna get one buck up and buy a dynatek one. They are the best out there, many have had problems with the cheaper ones(like procom). Also you should put in heavy duty valve springs in before you get a rev box if you haven't already.
 

·
Registered
Joined
·
4,131 Posts
I don't know about that black box, but I bet it's all the same cdi box as the procom, revmax, and big gun. I have a procom, it's been in my bike for about 3 years with no problems. But a lot of people have ran into a bad batch of them. That black box has a 1 year manufacture warranty on it, so at least it will last you a year lol. Get some drz valve springs, they are a bit stiffer which will help slap the valves down faster at high rpm's to prevent valve float:cool:
 

·
Registered
Joined
·
2,225 Posts
great advice on the valve spring upgrade with a cdi guys. nice

I have just bought the DYNA CDI, cant wait to try it out
 

·
Registered
Joined
·
528 Posts
Buy a dyna! Il sell ya my procrap though : ) haha cant go wrong with the adjustability im definatly ordering a dyna in near future
 

·
Super Moderator
Joined
·
5,886 Posts
Search this topic, it's been covered many times. Then, buy a dyna.
 

·
Registered
Joined
·
3,018 Posts
i also found out if you have an older z and the guy before you didnt take care of it, the constant high rev will toss out your rod bearing. i would make sure the engine has lots of life left before making it a high rev motor. i did rings, new valves, springs, but the guy before me didnt take care of it. shoot when i first went to look at it, it was sitting in the middle of his yard and there was a goat tied to it and it looked to be in serious shape. motor ran great, no smoke no noise but about a month after installing the rev box the bearings took a crap. so i parted her out and took over my wife nikki's
 

·
Registered
Joined
·
2 Posts
I have a problem with my ltz 400 that limits me in the first gear to a few rpm as if the rev was stuck I changed the reversing sensor eh checked all the stator wiring I only put it in my first change it limits me and cuts off the current. If I change the CDI it would be a good request
 

·
Super Moderator
Joined
·
4,510 Posts
It sounds like you are stuck in the reverse limiter. It could be a gear position sensor, CDI, or wiring.
 
1 - 11 of 11 Posts
Top