Suzuki Central Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
Hello. My sons Ltz 400 has a cracked headlight cover. Took on water and now both low and high beams aren’t working. I checked voltage from the switch and it’s good. But I can’t for the life of me get the bulbs out to check. Do they remove from the back? I thought just a twist would do it, but they won’t budge.
thanks for any input.
 

·
Super Moderator
Joined
·
4,992 Posts
What year? 2009 and newer, the headlight is replaced as an entire assembly. 03-08 you change the bulb by pushing in on the socket and turning to the left, then the bulb comes straight out.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #4 ·
Thank you. :) problem is a bit of rust my sons lens has a pretty big crack and water got in both the high beam and low beam. I got them out and both bulbs the glass was broken. Looks like I’ll try to find a headlight assembly
Thanks for the help.
anyone have an extra headlight assembly laying around ;). It’s an 06.
Thanks again.
 

·
Super Moderator
Joined
·
4,992 Posts
Post in the wanted section, you’ll probably find one. Traffic has slowed a bit here, so it may take a a week or 2 to find it.
 

·
Registered
2004 LTZ400 Limited Edition
Joined
·
1 Posts
Hey man- I’m in the same kind of situation as your son, I bought an 04 ltz400 a couple months ago and the headlight lenses are cracked and one bulb socket is completely rusted out. I have been looking at Chinese replacement assemblies on ebay for about $80- I was hoping someone had some experience with them and if they are good or not. It would be much cheaper than an OEM assembly! Good luck to you and your son

 

·
Super Moderator
Joined
·
4,992 Posts
None specific to the Z. I think there is a Facebook group that’s more active.
 
1 - 9 of 9 Posts
Top