Suzuki Central Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter #1
this was the first time i've taken the dipstick out on the Z and when i unscrewed it oil just over flowed, bout a 1/4 of a quart i bet ended up on my driveway.. i dunno whats up with this, i've never seen this type of thing b4.. can anyone give me some idea's here...
it doesn't much matter since i'm at my 10hr mark and i'm gonna change the oil in the morning anyways but just for some piece of mind i was wondering whats up.. thankx
 

·
Registered
Joined
·
970 Posts
That is really strange. How long had it been since you rode it? Check your plug. They must have overfilled it and you might have gotten a lot pushed past the rings. The oil settles in the crankcase the longer it sits. Someone just plain overfilled it.
 

·
Registered
Joined
·
320 Posts
overfil

i am assuming you shut the bike off before you checked the oil right? I mean, i know that sounds stupid, but it isnt like a car, it is a dry sump system, if it was running it would pump the oil right out of the dipstick
ac
 

·
Registered
Joined
·
40 Posts
Discussion Starter #4
i rode on thursday night, and everything was fine, no blue smoke or any signs of oil getting past the rings..
the quad was not running when i took the dipstick out. i'd just moved it from my backyard into the driveway out front and shut it off and went in the house to get a shop rag and i came back out after bout 5 minutes and pulled the dipstick and then came the oil, overflowing...
 

·
Registered
Joined
·
379 Posts
Most of the assemblers are a bunch of border hopping hacks. After I got my Z I came home to tighten everything down and probably 40% off the stuff was loose or not tight enough. People talkabout their spark plugs not being gapped right and now oil being too full now too.
 

·
Registered
Joined
·
45 Posts
The first time I checked my oil the same thing happened. I have changed my oil since then and no problems.
 

·
Registered
Joined
·
186 Posts
Wowzerzs!!!! thats a lot of extra oil.........I would smell the oil to check for gas? Hard to believe they would put that much extra in. :roll:

I had checked my oil soon after I got mine, it was right on the full mark.
Wouldnt the dealer check oil level?????

Only thing to find loose on mine so far was the handlebar clamp. :?
And the rear brake light switch out of adjustment.
 

·
Registered
Joined
·
23 Posts
it happened 2 me but i just rode it so i thought it was to hot.it happened 2 my mojave when i rode 4 a while and had 2 much oil
 

·
Registered
Joined
·
300 Posts
Happened to me

Same thing happened to me.

I changed the oil and filter and have not had any problems.

I check before every ride to make sure it's at the right level.
 

·
Registered
Joined
·
100 Posts
That is the Dealers screw up!!

The same thing happened to mine, but I noticed it at the dealer b4 I brought it home.

They said they must have added too much oil, since it was a tricky system to check the oil level on.

Make sure you follow the procedure in the manual for checking it, and when you change the oil measure the amount stated in the manual out and then fill it.

LOBE"
~~~
 

·
Registered
Joined
·
13 Posts
hhmm,
that seems strange they would put THAT much extra oil in.....is the oil like a milky color? your water pump could be leaking into it
 
1 - 11 of 11 Posts
Top