Suzuki Central Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
970 Posts
Discussion Starter · #1 ·
We'll see how it does in the morning. It started up really bad and idled like crap for 5 minutes. I ran it in for a few and it runs ok now, but the idle still hunts a bit. The cam is a LOT bigger and it revs like it did before after breaking the cam in a bit. I'll take it easy for 20 minutes, but throttle response seems crisp. I just need to make sure it gets the proper tune.
Here's my setup: I just went with a 25 pilot, 3 turns out on the mixture and I have a 155 main in there. I'll check the topend tomorrow but is 3 turns with a 25 pilot reasonable?
I also went with a .035 gap on a new plug.
 

·
Registered
Joined
·
970 Posts
Discussion Starter · #2 ·
Well, it starts up and idles great now. Sometimes when you rip everything apart, drain the gas from the carb and just have crap everywhere I guess it takes time to fill the bowl and get everything wet again.
 

·
Registered
Joined
·
384 Posts
dont you have to bump up the compression and run race gas if you run both the cams?. i thought that was hotcams recommendation among other engine builders. im probly wrong though
:
 

·
Registered
Joined
·
582 Posts
Where did you get the 25 pilot jet Barely Legal? Hows it running now?
 

·
Registered
Joined
·
970 Posts
Discussion Starter · #5 ·
You don't have to bump the compression. The only way to do that is change the head gasket or the piston. To gain some torque back it's a good idea. I'm going riding in a few minutes so I'll have results this afternoon.

I got the 25 pilot from Alba for $2.
 

·
Registered
Joined
·
22 Posts
exhuast valve lash?

hey barely legal whats your exhuast valve lash set at? i pm'ed you earlier with my setup and was just wondering if your valve lash was dead on. seems like i had to do a whole lot more with my valve settings then what hotcams discribes in the instructions. to go from .315 shims to .290 seems a bit much. the intake cam valve clearance was perfect but the exhuast was way tight. the idle is great but 1/2 to 3/4 throttle stumbles and misses hard
after 3/4 throttle it runs great. i tried jetting up but the stumble was worse,
so i kept jetting down till the stumble was not so hard. now i am at a 132 main and don't want to go to lean. the stumble is noticable but after it clears up the bike really rips.. need help with this. anyone have any suggestions?
 

·
Registered
Joined
·
394 Posts
Slammer...

Different profile cams will always have a different shim settings. My WEB cams were the opposite, they used larger shims, I'm thinking I used 350s for intake, and 345s for exhaust...it was pretty rediculas, those are the two largest sizes Suzuki offered.
 

·
Registered
Joined
·
1,176 Posts
And the verdict is?
 

·
Registered
Joined
·
22 Posts
finially !

well barely legal i got. and its ripping through the gears like never before.
remember i had a hard stumble at 3/4 throttle, so i went up in jet size and got worse, started going down in jet sizes got to a 132 with just a slight stuble. tried going up on the needle and nothing,went down and nothing.
so decided to just go with the biggest jet i had wich was a 155 and set my dial a jet to the center hole, removed the air box lid.
guess what it worked! so all this time the bike was struggling for air and more fuel. heres what i have:
yoshi complete system-prodesign proflow air filter and adapter-dail a jet-
dynojet 155 main-neddle on 4th slot down-je 12:1 high compression piston-
int.& exh. hotcams. exhaust valve shims at 300- air box lid and snorkel removed. and now we are ready for lift off!
shooo.. time to stop spending, before long the z will be worth more than my truck.
this is all the motor mods i will be doing for a while...
 

·
Registered
Joined
·
970 Posts
Discussion Starter · #11 ·
Cool. Glad to hear you got it. I'm done modifying for now too. Might be worth more than my vette soon. :roll: (uh, the vette has mods to though, so I guess I'm ok there)
 

·
Registered
Joined
·
970 Posts
Discussion Starter · #13 ·
It was not any better than stock I'd say. I lost the ability to pop the front end up in the first three gears and clear rocks and stuff. It just revs out but the power is nowhere near as usable. The quad was actually slower with a bit more top end power.
I took the exhaust cam out and now it rips again.
 

·
Registered
Joined
·
394 Posts
Hey BL whats the specs on the Hot Cams exhaust cam?
 

·
Registered
Joined
·
384 Posts
you really need to bump the compression up and get the rev limit changed to see the benifits of the exhaust cam
 

·
Registered
Joined
·
22 Posts
bump compression

yea, i'm glad i went with the je 12:1 high compression piston with both cams. my low end is five times better now than with just the yoshi complete system. midrange is just unbeleivable and top end feels like i could use another gear, so i think now i'm gonna install my 15 tooth front and my 39 tooth rear sprockets. and will still have a good low end with supurb mid and top end.
b. l. i said iwasn't doing any more mods.. but one more :D
port and polish the head. then thats it.
i found a guy about 40 miles from hear that ports heads and he said every ting that i put into my z so far won't compare to a port and polished head.
so 2 weeks from now i will have it done.
will let you guys know if its worth it...
oh forgot to mention i have to run sunoco 114 octane now. its a leaded fuel.
the unleaded was running too dry.
 
1 - 16 of 16 Posts
Top