Suzuki Central Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Hi all just got myself a road legal z400 (first quad)2005 done 500 miles from new took it out today on the road an law behold after a half hour running gave it the beens and got to top gear an it chucked it ??

checked i still had fuel (as id left wi a full tank) checked the tank vent
which was clear but after a couple of mins an a couple of times trying to start it fired into life an drove home prefect but only took it up to 40mph

any ideas what i could check before i go out again !!

Cheers Kevy ;)
 

·
Registered
Joined
·
202 Posts
By "chucked it" do you mean it died?
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #6 ·
Come back and let us know how it all looks. And welcome to SC!!! great first post
Ye will do il do the checks tonight an test it in the morning as not got
much daylight left an im in a rural area dont fancy being stuck at night
round here (everyone drives as if they just stole it) lol

Cheers Kev !!
 

·
Premium Member
Joined
·
4,285 Posts
make sure an intake boot or filter or airbox snorkel didnt fall off or out of place. anybody who tried to take a snorkel off of a stock machine knows how well that works!
 

·
Registered
Joined
·
463 Posts
I think what he means by midges are those evil little gnats that swarm you but don't bite too hard, just fly in your eyes ears and nose and drive you crazy!
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #13 ·
make sure an intake boot or filter or airbox snorkel didnt fall off or out of place. anybody who tried to take a snorkel off of a stock machine knows how well that works!
Ok nice one thanks for that ;)

I think what he means by midges are those evil little gnats that swarm you but don't bite too hard, just fly in your eyes ears and nose and drive you crazy!
ha ha thats the ones they bite but just give you loads of red lumps an they itch like hell especially when bitten in the eye lids lol
 

·
Registered
Joined
·
1,544 Posts
Oooo. That must suck bad! I got bite on the eye lid once. Don't want it to happen again!
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #18 ·
Ok seems to be all sorted now :D

removed fuel lines & tank cleaned out the valve and found some dirt & sludge around the small filters,cleaned up & filled with fresh fuel and away she goes much more power now & never missed a beat :clap:

Thanks very much lads much appreciated :D ;)
 

·
Premium Member
Joined
·
7,168 Posts
Glad you got it running! Post some picts of your z when you get a chance. Welcome!
 
1 - 20 of 21 Posts
Top