Suzuki Central Forum banner
1 - 7 of 7 Posts

· Registered
2006 ltz 400
Joined
·
4 Posts
Discussion Starter · #1 ·
I have a 06 ltz400 that now has the click but no start issue. I believe it’s a faulty starter because I can smack the starter and it’ll try to crank but then goes blank. I was wondering if it’s better to replace then brush holder set, or can I get away with the cheap eBay starters?
 

· Registered
Joined
·
459 Posts
Cheap Starters are hit or miss, I have seen ones that lasted years and others day's. If you can get the parts I would rebuild the OEM or find an OEM one if It was me.
 

· Registered
2006 ltz 400
Joined
·
4 Posts
Discussion Starter · #3 ·
Cheap Starters are hit or miss, I have seen ones that lasted years and others day's. If you can get the parts I would rebuild the OEM or find an OEM one if It was me.
Thank you so much. I’m probably just gonna clean up the commutator bar and buy a new brush set, I’ll let you know how it goes when I fix everything up.
 

· Administrator
Joined
·
4,025 Posts
Had good luck with one on my 250.... Would get another one..
 

· Registered
Joined
·
19 Posts
Hello everyone
Hey I would just by a new starter also dont be" penny wise & dollar foolish". true sometimes they are hit and miss but on E Bay& Amazon you can but extended warranty worth the few extra bucks that should keep you good to go for quite sometime ( I bought a battery from Amazon sealed lead acid battery $19 the AGM Li Ion are junk personal experience)& you need a specific charger if not a lead acid type for my LT 250 bough the square trade 3 year extra for a few bucks, we all know even if you take care& keep battery trickle charger on it you are lucky to get a year (y) 🤔
 
1 - 7 of 7 Posts
Top