Suzuki Central Forum banner

1 - 20 of 26 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter · #1 ·
I bought my 2003 z400 about a month ago, I got it for a very good price so I originally didn't mind the minor hiccups it has. I'm to the point now to where I really want to get it running really smoothly. The only mods that I can see are a K&N filter (looks likes it's been in there for a very long time) and a full Yoshi "off road" exhaust, still has the spark arrester in. Also, the choke cable isn't working completely for some reason . . I need to check that out.
I'm under the impression that it's running lean. Then again, I could be wrong and it's running rich. I dunno, that's why I'm posting.
At first startup it normally starts up and idles fine. If you ride around before it's completely warmed up and crack the throttle it cuts out and then will rev back up through the gear. After it's warmed up you can pretty much throw whatever you want to at it in 1st and 2nd gear. But if I get on a long stretch it cuts out at the top of 3rd, a little lower in 4th and a little lower in 5th.

Also, I tried running without the airbox lid but it bogged it down very badly.

How do I make it run like it should?!
 

·
Registered
Joined
·
242 Posts
pull the carb and look at the Jets and see what is currently in there with a K&N and pipe i would hope it has been rejetted. the easiest way to rejet it is to get a Dynojet kit.
this will give you an adjustable needle and jets -

pull the plug and see what it looks like - if black rich - if white Lean
do plug chops and check the plug.
Since pulling the Airbox lid makes it run worse i would say your running lean
 

·
Registered
Joined
·
1,410 Posts
No it's not jetted.. Or at least not jetted with big enough jets
You need to get some bigger jets, or a jet kit
 

·
Registered
Joined
·
1,676 Posts
Take your carb off and clean it real good, fix your choke, and write down what pilot and main jet is in there. Then post what your jets are and some one will let you know what jet you need to get. You might want to check your valve lash while your taking things apart. Good luck.
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #5 ·
Alright, thanks for the quick responses guys! I'll probably tear it down after I get home from work, I've got to replace a front wheel bearing too . . . :/
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #6 ·
Went to take the spark plug out and this is what i found. . .




also, took the carb apart and it's pretty dirty . . .
 

·
Registered
Joined
·
1,676 Posts
That sucks. I'm sure you can find a coil w/plug wire from one of our members at a good price. Did you find out what jet sizes you have in your carb?
 

·
Registered
Joined
·
800 Posts
wow that rig job is not a good sign, i wonder what your valves, valve lash, piston, rings, cylinder, clutch, timing chain, and oil look like
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #9 ·
took the valve cover off and discovered it's just a bad gasket. Not so bad then, yea?

BACK TO THE JETS: I took the carb apart, the fuel screw was about 4 turns out and it appeared to have all of the stock jets? only 1 out of the 3 had any signs of a size on it, it said 60 on it? I guess that's the pilot? I dunno?
 

·
Registered
Joined
·
1,676 Posts
If its the stock carb, 60 isn't the pilot. If I remember correctly, stock jetting is 22.5 pilot and 145 main. I would check the jetting database for more info, but 25 pilot and 155 main may be a good starting point for your mods. Did you take the tape off your spark plug boot? Maybe it will still work if someone just put tape on it to help shield it from the oil? You can try cleaning the boot, put a plug in it, then ground the plug and check for spark. If not, there are lots of part-outs posted.

BTW: If you haven't done it, you may want to check your cam chain tensioner to see how many clicks are left and since you valve cover is off, check the valve lash too.
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #12 ·
Thanks man. I would be all about reusing the old coil and plug wire but it fell apart as I was taking the tape off . . . I figure buying a used one in a partout would be pretty cheap and safest way to go. and I plan on ordering a new gasket from Rockymountainatv made by Tusk? good? bad? ugly? The stealership said it would be 25 bucks for a new gasket . . You don't even wanna know what they charged for a new coil and plug wire . .
 

·
Premium Member
Joined
·
5,886 Posts
Check your valve lash while you've got that cover off! How much did they want to charge for the coil and wire?!
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #14 ·
Haha alright!!!! Anyone wanna link me to a how-to thread? I adjusted the valves on one of our prairies a couple years ago, need a little refresher. and they wanted 60 bucks for a new coil and wire . . .:eek:
 

·
Premium Member
Joined
·
5,886 Posts

·
Premium Member
Joined
·
5,886 Posts
It's gotta be done... You're already 90% of the way there, just set to tdc and stick the feeler gauge in!

PS:get rid of that choke cable and get a pull choke.
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #20 ·
Got my new gasket in today. Everything went together smoothly, seems to run just a tad better after cleaning the carb a little bit. Still running lean, though. Anxious to re-jet and see where that puts me. As it sits, it only pulls a wheelie in 1st and 2nd. From what i've read it should pull through 4th pretty easily, right?
 
1 - 20 of 26 Posts
Top