Suzuki Central Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter #1
My quads were stock with yoshi pipe and header. They left the jets alone said they run fine how they are. Runs great not even finished breaking in yet. Soon my alba K&n kits will be here and i know i will prolly hafta jet after that. I ride at a mile high plus, 5800 feet around here. I plan to keep my lid on as the dust here is intense. What jetting do you think i will need? Any info is welcome. Not much of the type to do it myself but i may cause i'm broke atm. lol :p
 

·
Registered
Joined
·
197 Posts
this may or may not help. I know my dealer sells Zs with yosh slip ons. I know a person that bought on and they told him that it would not need a rejet cuz it would not do anything for him. HA, he ended up messing with it and found that the jetting wasnt even near acceptable. I dont know what he ended up at for jetting, but I know he messed with it for a while and chaned the jets 6 times before he got it where he wanted it.

I know it dont help much, but it does let you know that dealers dont have much of a clue when it comes to performance.

jakhammer
 

·
Registered
Joined
·
78 Posts
Discussion Starter #3
Yea i know, i just got back from a ride and it needs jetted as is imo. I know after the filter it will HAVE to be jetted. Its allready sputtering when letting off the gas. I told him they should have been jetted but he said i'm the only one here with non stock ones. He also said i'd be the first here with a K&N kit as he could not get them. *Shrugs* :roll: :?
 

·
Registered
Joined
·
78 Posts
Discussion Starter #4
Looks like i'm hosed. I'll have to buy a crap load of jets and pay out the ass to have them change em till it runs right. Man this realy sux. I should have just left them stock. I have my K&N's now but i dont dare put them on or i doubt they will even run.... :evil: I also got my skids but i cant get any of the 5 screws off. I have nothing that seems to fit. :? Just my normal amount of luck.. In the - area, lol.


If its backfireing when i let off the gas is it running lean? I'm still pissed at the place i got them, they should have been jetted when they sold them to me with full pipe/header setups... :evil:
 

·
Registered
Joined
·
3 Posts
:idea: Hey Pretender!
I'm in about the same predicament as you-full Yosh, but want to keep the lid & snorkel. With the stock 130 main, mine backfires a little when I let off the gas too. I think a backfire is caused by fuel igniting in the pipe somewhere which tends to mean a rich condition. However, it might be something we will have to put up with, as on a throttle chop, all engines are in a rich condition for a split second. Let me know your final jetting when you get her right. Good luck. Zplane!
 

·
Registered
Joined
·
78 Posts
Discussion Starter #6
Well now that i have my filters on and since i ride at 6000-13000 alt i dont think I need to jet. They are running just fine besides a backfire every now and then. But i'll change the plugs and see what i cant do without jetting. If i still have probs i'll be getting a dial-a-jet since i like to ride at super high alt. :twisted:
 

·
Registered
Joined
·
78 Posts
Discussion Starter #7
Now that there past break in i went out and opened em up to the max in each gear and i have to say they are running freaking sweet. 6000alt stock jet yoshi pipe/header k&n high flow with lid on and snorkle on running like a dream. The power band just never ends. I couldnt be more happier with em. Sure i could handle more power but they are great for the light wheight. :twisted: :p :twisted:
 
1 - 7 of 7 Posts
Top