Suzuki Central Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hey I've lost spark on my 2004 ltz 400 I've changed the fuse and tested the coil and went down the whole wiring harness and can't find any problems could this be my cdi box or my stator ?
 

·
Super Moderator
Joined
·
4,138 Posts
Could be any of those. No way to test the CDI except swapping it out for another one. The CDI harness has been known to short or have the pins back out at the CDI. Stator plugs sometimes short out as well and the stator itself can’t really be tested correctly with just a multimeter. The end of the plug wire can corrode and break as well.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Okay thanks I'll check those things I did have to rewire the cdi connectors but I did have spark after that and then it blew a fuse and I put a new 30 amp fuse in it because that's the one I took out and I've didn't get spark since
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
Could be any of those. No way to test the CDI except swapping it out for another one. The CDI harness has been known to short or have the pins back out at the CDI. Stator plugs sometimes short out as well and the stator itself can’t really be tested correctly with just a multimeter. The end of the plug wire can corrode and break as well.
Okay thanks I'll check those things I did have to rewire the cdi connectors but I did have spark after that and then it blew a fuse and I put a new 30 amp fuse in it because that's the one I took out and I've didn't get spark since
 

·
Super Moderator
Joined
·
4,138 Posts
Is the engine cranking?
 

·
Super Moderator
Joined
·
4,138 Posts
I’m guessing whatever smoked your 30amp fuse fried something else, too. If it is cranking, then that 30amp is still good. All of the other fuses ok?
 

·
Super Moderator
Joined
·
4,138 Posts
Oops, wrong machine. The Z only has the main fuse. What were you getting on the coil resistance check?
 

·
::3 Pump Chump!::
Joined
·
2,994 Posts
Oops, wrong machine. The Z only has the main fuse. What were you getting on the coil resistance check?
What is the output of the stator on each leg? What is the output before and after the rec/regulator? What is the output at the coil.

normally your coil is a red lead off the stator.
 
1 - 10 of 10 Posts
Top