Suzuki Central Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I have an 04 ltz 400 bored out to a 440 with an hmf silencer and a powerbomb header pipe. Pretty sure it's jetting as it wont idle right and it's popping on decel a lot. Any ideas on what jetting should be for this setup. I ride around 20ft to 600ft above sea level. It is a stock carburetor. Let me know if you guys want more info.
 

·
Super Moderator
Joined
·
3,765 Posts
Check out the jetting database, and look for similar setups. If all jets and passages are clean, then you need to get more fuel to it, with the Fuel Screw and/or Pilot jet. Probably one size up on the Pilot will take care of it if the fuel screw wont at 3 turns. Check out the Dynajet intstructions for their kit.
 

·
Super Moderator
Joined
·
3,765 Posts
Try a 25 Pilot, and that 130 will be lean up top as well. If you pay the big bucks for the Dynjet kit, you get the good adjustable needle, and a good selection of jets, most of which are unusable..:)
 

·
Registered
2003 suzuki ltz400 big bore
Joined
·
28 Posts
I bought the dynojet kit.

I have very similar setup

Big bore, k&N filter open airbox, stage 2 cams and slip-on.
I'm at 500 ft above sea level and Im running a 160 main, 25 pilot and 2.5 turns out and runs great (no popping, no bogging/loss of power anywhere etc)

Did you adjust the throttle position screw on the carb? Took me a min to figure why mine idled so high this morning and turns out my kids had been twisting it and had it too tight (partial throttle on)
 

·
Super Moderator
Joined
·
3,765 Posts
Rejetted and now it's smoking blue. Could it be the fuel quality I'm running? I'm using 87 unleaded... upped it from a 130 to a 155
How does it run? Blue tends to be oil, fuel is generally black. I wouldnt run 87 in a big bore, your asking for trouble, IMO.
 
1 - 11 of 11 Posts
Top