Suzuki Central Forum banner
21 - 34 of 34 Posts

·
Registered
2003 suzuki ltz400 big bore
Joined
·
19 Posts
Discussion Starter · #21 ·
Automotive tire Wheel Hubcap Tire Motor vehicle


Quick clean on left exhaust valve and looks pretty good so will see how new valves sit.

I'll prob ask if local shop has an old one I can use to lap if it needs it. Can't see me buying a wiseco to toss out since it'd cost me like $60 cad before shipping even
 

·
Registered
Joined
·
421 Posts
Id clean up best you can I think you'll be fine.
 

·
Super Moderator
Joined
·
3,739 Posts
I'll prob ask if local shop has an old one I can use to lap if it needs it. Can't see me buying a wiseco to toss out since it'd cost me like $60 cad before shipping even
Where are you located?
 

·
Super Moderator
Joined
·
3,739 Posts
I'm 2 hours East of TO. I should have old valves, but not sure I could find them anyway.
 

·
Registered
2003 suzuki ltz400 big bore
Joined
·
19 Posts
Discussion Starter · #26 ·
I'm 2 hours East of TO. I should have old valves, but not sure I could find them anyway.
Ya.. Picton is a bit of a drive 🙂

I'm just going to see how they seal with new valves, springs etc I have coming. If they are terrible and leak a lot, I'll bring it to local bike shop and see if they can give me a hand. Nice thing about being small town area... Local small shops usually pretty good to assist for a case of beer
 

·
Registered
Joined
·
31 Posts
Hi all.

Been lurking forums for a while and have received a ton of help already. Bought a used ltz400 that I've been trying to get running. Just looking for helpful hints so I know I'm in the right direction.

Bought non running but just came back from shop having new head (big bore 434cc), new piston and rings, cam chain done. I just can't get it running now.. Here is what I've already done....

Did coolant flush and oil change
Good spark and new plug (checked stator as well and checks out fyi)
Replaced oil pump gear and checked oil pump
Cleaned carb and installed dynojet jet kit (155 main etc) I double checked this also but I'm not sure it's giving fuel for some reason as spark plug never seems real wet)
Checked valves and fixed (they were quite out.. Now within spec) and double checked again after rotating and back at tdc.
Timing is bang on.. I double checked it also
New battery

Next and only thing I can now think of is if new rebuild has busted rings and no compression (or very low) and/or carb for some reason I can't see or tell isnt working.

I'm only well versed in repairing small honda motors so this is all new to me and a bit more advanced.

Is my next step to verify compression and if it's good, replace carb?
CHeck the timing. . 10 and 2 I believe. My hotcams are new style and and are slightly off. But that's how they are to be
 

·
Registered
Joined
·
31 Posts
Hi all.

Been lurking forums for a while and have received a ton of help already. Bought a used ltz400 that I've been trying to get running. Just looking for helpful hints so I know I'm in the right direction.

Bought non running but just came back from shop having new head (big bore 434cc), new piston and rings, cam chain done. I just can't get it running now.. Here is what I've already done....

Did coolant flush and oil change
Good spark and new plug (checked stator as well and checks out fyi)
Replaced oil pump gear and checked oil pump
Cleaned carb and installed dynojet jet kit (155 main etc) I double checked this also but I'm not sure it's giving fuel for some reason as spark plug never seems real wet)
Checked valves and fixed (they were quite out.. Now within spec) and double checked again after rotating and back at tdc.
Timing is bang on.. I double checked it also
New battery

Next and only thing I can now think of is if new rebuild has busted rings and no compression (or very low) and/or carb for some reason I can't see or tell isnt working.

I'm only well versed in repairing small honda motors so this is all new to me and a bit more advanced.

Is my next step to verify compression and if it's good, replace carb?
10 to 1 its the timing. . Maybe they didn't put it back togather the correct way after bbk. I have stage 1 hotcams and athena 440 I put In mine. Just got the fcr mx carb from keihin and man it is bad a$$ . Carb will factor over it all
 

·
Registered
Joined
·
31 Posts
Ok so ordered hot cams stage 2 and full set of kibblewhite valves and springs etc. And yes...my wife wants to kill me.

My question (and hard to find an answer it seems) is how do I know if my valve seats are good? They 'look' okay (I just wiped them clean etc)

Since I can't use compound on the new titanium valves and my old ones are bent, what's the best method to get a good seal and how to I check seats?
You'll know if the seat or not lol I didn't do mine yet but I did my yfm100 last year and was able to tell they sat
 

·
Registered
2003 suzuki ltz400 big bore
Joined
·
19 Posts
Discussion Starter · #30 ·
10 to 1 its the timing. . Maybe they didn't put it back togather the correct way after bbk. I have stage 1 hotcams and athena 440 I put In mine. Just got the fcr mx carb from keihin and man it is bad a$$ . Carb will factor over it all
Yup.. Already confirmed cams are shot and valves bent. Hot cams stage 2 and new valves on order.

I'm already 1k over budget so no carb upgrade for me. Wife's gonna want divorce when I come home with my 'new to me' 2014 freeride on Saturday
 

·
Registered
Joined
·
31 Posts
Yup.. Already confirmed cams are shot and valves bent. Hot cams stage 2 and new valves on order.

I'm already 1k over budget so no carb upgrade for me. Wife's gonna want divorce when I come home with my 'new to me' 2014 freeride on Saturday
Hey brother. I fell ya I thought I was a dead man too after I put over 4 grand into mine lol.... you have a 14 ltz.. I'd love a newer quad . Mine is 03 but almost completely redone just need to do the valves and the actual gears not the clutch pads.
Automotive fuel system Fuel tank Automotive lighting Automotive tire Motor vehicle
 

·
Super Moderator
Joined
·
3,739 Posts
Hey brother. I fell ya I thought I was a dead man too after I put over 4 grand into mine lol.... you have a 14 ltz.. I'd love a newer quad
Pretty sure the Freeride he was talking about is a snow thingamajiggy.
 
21 - 34 of 34 Posts
Top