Suzuki Central Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
ok i bought a 04 kfx 400 the other day off a close freind who let me ride the bike before i bought it for several hours to make sure i liked it, well i did and i bought it, hauled it home rode it a little, this was a friday evening, and saturday i rode the bike all day. i hadnt had much time to ride it this past week but i did go start it and let it warm up every evening. well ive owned the bike for 1 week and 2 days and have probably put 12hrs on it.. well yesterday i ran it out of gas so i had to be hauled home. i filled it up with gas and rode it a little more, until it quit........ and heres the thing ive cleaned the carb, changed the gas because it had been in a can an i thought maybe it had water in it.. and ive cleaned the spark plug.. the problem is it bogs down really bad when you try to rev it, and sometimes backfires.. im lost ive already adjusted the fuel mixture skrew anywhere from 1/4 turn to 4 turns and it does the same thing no matter what, the bike is mostly stock, (k&n filter and fmf exaust).. it idles great just wont rev, especially when you hit the throttle hard it dies, but if you ease into it it will rev up but when its reved it pops and snaps.. im new to this whole thing and ive been on here all day trying to figure it out..... any help is appreciated
thanks, nick
 

·
Administrator
Joined
·
12,453 Posts
Do you know if the jets are stock ? If they are you will more than likley have to get some bigger jets. Is the fmf a full exhaust ?
But it ran fine before he ran it out of gas.
Clean the Petcock......
Check the choke in the carb to make sure it isn't stuck.
Did you clean all the jets......most notably the pilot jet?
Air filter clean?
 

·
Premium Member
Joined
·
5,886 Posts
Like spize said, make sure you're getting fuel. There may be enough vacuum to open the petcock at idle, but not enough under higher rpm's. Try running it on pri.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #5 ·
ok, ive cleaned the petkock an put it on prime, took the carb off and cleaned it again, now it will idle and if u hold it wide open it will cut out then catch up.. the fmf is a slip on,
thanks for the help, and the air filter isnt dirty,
 

·
Registered
Joined
·
143 Posts
I'm pretty sure its not the jets, if it was running great before it ran outta gas. Did you check your choke like spize said? And also what octane gas did u put back in it? Cause I know mine has a slip on yosh and uni filter without lid and if I run anything under 91 octane gas in it, it runs like shat!
 
1 - 9 of 9 Posts
Top