Suzuki Central Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hi there. I'm new to the community.

Owner of a 2003 Z400. Pro-Design Airflow Kit is the only upgrade I've done to the quad. When I bought it in 2010 the owner said he believed he jetted the quad so he could ride it in higher altitudes. I have never re jetted. I did have it serviced for carburetor and unsure if they would change this or not....

Anyways the quad has not been ridden much in the past year. I put a new air filter in, changed the oil, spark plug and petcock. The quad still is not reliable. I sometimes have trouble getting it started but once it's started I can run it around the neighborhood for a bit. If I get on the throttle for a bit it then seems to bog or die. I then can't start it for awhile. Maybe 5 minutes and then I can limp back home.

I noticed the red oil light turn on not while riding but once it died and turning the key back on. I then noticed the fan wasn't coming on while sitting there. I pulled the lower switch and jumped the wires, the fan comes on fine. So unsure if something is wrong there.

Do you guys have any good starting places for me? I was thinking of buying a carburetor kit and doing that next....

Thanks!!! IMG_0241.jpeg
 

·
Registered
Joined
·
7 Posts
Discussion Starter #2
Oh and I was just checking the reservoir tank to see how much fluid was in there. I was dusting it off and my finger went right through the plastic :ROFLMAO: anybody know where to get a cheap one? thanks
 

·
Super Moderator
Joined
·
4,191 Posts
Sounds to me like it’s starving for fuel if it won’t restart until it sits for awhile. Try cracking the gas cap loose a little to be sure it is venting properly and not causing a vacuum in the tank.
Also, does it do this with the petcock on Prime or On? Another thing to try is when it dies, immediately open the carb bowl drain and see if fuel comes out the drain line.
Of course, cleaning out the carb also fixes lots of fuel delivery problems. While your in there, take the jets out and tell us what numbers are on them.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
Sounds to me like it’s starving for fuel if it won’t restart until it sits for awhile. Try cracking the gas cap loose a little to be sure it is venting properly and not causing a vacuum in the tank.
Also, does it do this with the petcock on Prime or On? Another thing to try is when it dies, immediately open the carb bowl drain and see if fuel comes out the drain line.
Of course, cleaning out the carb also fixes lots of fuel delivery problems. While your in there, take the jets out and tell us what numbers are on them.
Sorry for the delayed response. The reason being is that I had to replace the overflow container as it was cracked before I gave it another try. So to answer your questions first. The petcock is a new cheap Chinese version of the petcock that does not utilize the vacuum line. So it has an on, off and reserve. I have tried the different positions with the line off and gas poured out on all except for off.
Okay so today I was able to give it a go. I had trouble starting it and had to jump it. Once I had it going I cruised around the neighborhood at low speeds for 20 minutes. Also noticed fan never came on. After that I decided to give her all she got. After about 30 seconds at full throttle she shut down. I did have the gas cap loose at the time. I pulled over and sat for about five minutes. I did not have my screwdriver on me to try to empty the bowl. Waited about five minutes and she started back up and made it home. I just can’t ride this thing if I can’t give it gas
 

·
Super Moderator
Joined
·
4,191 Posts
It’s probably that petcock. Some of them are known to supply less than the required amount of fuel at WOT. Get a factory Yamaha raptor660 petcock and I bet your problem will disappear.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
It’s probably that petcock. Some of them are known to supply less than the required amount of fuel at WOT. Get a factory Yamaha raptor660 petcock and I bet your problem will disappear.
I was thinking that.
Okay placing an order for that part and will update again.
Thanks for your help!!
 
1 - 6 of 6 Posts
Top