Suzuki Central Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
2,340 Posts
Discussion Starter · #1 ·
Hi, so we got my Z400 put back together but when I rev it, it will rev but it won't let off the throttle instantly. Like when you rev its like "Wapapapap" but instead mine is like "Waaaaaaaaaaapapapapap" any help? When it revs correctly its like "Vraaam" but mine is like "Vraaaaaaaaaaam" It lets off the throttle slowly instead of instantly. Specs are in my sig.
 

·
Registered
Joined
·
2,340 Posts
Discussion Starter · #3 ·
Sounds like an air leak
There is NO air leak. The throttle is closed, we checked everything. The only thing we can come down to is the needle. It is stock, maybe an adjustable needle will help?
 

·
Registered
Joined
·
1,374 Posts
Did you check the carb to head boot? And the needle might if there isnt an air leak
 

·
Registered
Joined
·
1,410 Posts
a lot of times, a really lean air mixture could cause that (pretty much the same concept of having a leak).. what does you spark plug look like?
 

·
Registered
Joined
·
2,340 Posts
Discussion Starter · #6 ·
Yes, everything is sealed. Will resort to needle. If that don't work I will send it to a SM Mechanic.
 

·
Registered
Joined
·
2,340 Posts
Discussion Starter · #7 ·
a lot of times, a really lean air mixture could cause that (pretty much the same concept of having a leak).. what does you spark plug look like?
170 seems fine for the amount of air it is getting. Will also check though. After I get an adjustable needle.
 

·
Registered
Joined
·
1,410 Posts
What is the pilot? and the fuel screw setting?
does your quad go like "pop pop pop pop pop pop" on deceleration?
 

·
Registered
Joined
·
1,410 Posts
If it does, than it could be the pilot/fuel screw that needs adjusting because there is not enough fuel getting to the engine when you let off the throttle.. this could cause your hanging revs
 

·
Registered
Joined
·
2,340 Posts
Discussion Starter · #10 ·
If it does, than it could be the pilot/fuel screw that needs adjusting because there is not enough fuel getting to the engine when you let off the throttle.. this could cause your hanging revs
We already tried that. Not the pf screw.
 

·
Registered
Joined
·
2,340 Posts
Discussion Starter · #11 ·
What is the pilot? and the fuel screw setting?
does your quad go like "pop pop pop pop pop pop" on deceleration?
Stock pilot, Idk what they are stock. I never messed with that.
 

·
Registered
Joined
·
1,410 Posts
Does your quad spit and pop on deceleration? you probably need a bigger pilot jet..
 

·
Registered
Joined
·
2,340 Posts
Discussion Starter · #13 ·

·
Premium Member
Joined
·
4,285 Posts
if your pilot jetting is not right, often people need to turn the idle speed screw in to get a decent idle. this will almost always cause a hanging rev. set the pilot screw properly, which may require a jet change. then set the idle speed, and see how it revs.

also, if you use a screwdriver to push the slide up and release it, it should smoothly go down and CLUNK when it hits a positive bottom in the carb body. if not you need to take it apart and polish the bore and slide, and make sure its perfectly clean. if it doesnt go CLUNK, it probably is hanging up and vibrating its way down to an idle.
 
1 - 14 of 14 Posts
Top