Suzuki Central Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
found out the fuel valve is the problem.if i disconnect the vacuum hose to it,it runs fine,but only with the vacuum hose from the carb open.if i plug the vacuum hose it stalls right out. if i connect it,it will only run if you give it some throttle-but runs verry rich.anyone had this problem??how do i fix it?
 

·
Registered
Joined
·
238 Posts
does fuel run out of the hose thats connected to the petcock? The vacume one. It shouldnt. It sounds like fuel is bieng sucked into the carb through the vacume hose, which would be a faulty petcock. The vacume petcock has had problems if its the same one thats on the z400. I dont know if its the same one or not.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
QUOTE (McCnO5 @ Jul 24 2008, 12:28 PM) index.php?act=findpost&pid=687279
does fuel run out of the hose thats connected to the petcock? The vacume one. It shouldnt. It sounds like fuel is bieng sucked into the carb through the vacume hose, which would be a faulty petcock. The vacume petcock has had problems if its the same one thats on the z400. I dont know if its the same one or not.[/b]
fuel does not come out from where the vacuum hose goes.the thing that gets me is,it will run with the vacuum hose disconnected from the petcock,but if i plug the hose it shuts the engine right off.even if the petcock was working,the carb would still not be able to draw a vacuum through it,the petcock is sealed.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
QUOTE (lorman @ Jul 24 2008, 12:55 PM) index.php?act=findpost&pid=687283
fuel does not come out from where the vacuum hose goes.the thing that gets me is,it will run with the vacuum hose disconnected from the petcock,but if i plug the hose it shuts the engine right off.even if the petcock was working,the carb would still not be able to draw a vacuum through it,the petcock is sealed.[/b]
well its fixed now.dont know what i did,just took the carb apart again and cleaned it again.must have missed something.
 

·
Registered
Joined
·
1,430 Posts
Pour me some of what this guys having^^^^^^^
 

·
Super Moderator
Joined
·
4,337 Posts
Wtf?!
 
1 - 6 of 6 Posts
Top