Suzuki Central Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
433 Posts
Discussion Starter · #1 ·
i had my frront end up off the ground to ajust my shocks and saw that my right front wheel is acting funny, for some reason it can turn right untill the rim hits the a-arm, the other tire works like it should tho, not sure whats going on :angryfire:
 

·
Registered
Joined
·
2,340 Posts
Your tie rods fine?
 

·
::3 Pump Chump!::
Joined
·
3,047 Posts
Is your steering stop broken on your steering stem ?
 

·
Premium Member
Joined
·
5,886 Posts
I don't think it should turn till it hits the arms, there's a stop on your stem that hits the frame at full lock. maybe the other side has a broken stop.
 

·
::3 Pump Chump!::
Joined
·
3,047 Posts
I don't think it should turn till it hits the arms, there's a stop on your stem that hits the frame at full lock. maybe the other side has a broken stop.
me and you are like to peas in a pod lol... we got a S#($ on lock :icon_cool:
 

·
Registered
Joined
·
433 Posts
Discussion Starter · #6 ·
tie rods are strait lock is good and like i say the other side functions like it should
 

·
::3 Pump Chump!::
Joined
·
3,047 Posts

·
Premium Member
Joined
·
5,886 Posts
me and you are like to peas in a pod lol... we got a S#($ on lock :icon_cool:
Damn straight!

Basket, what about the frame where the stop is supposed to hit, is that bent or missing?
 

·
::3 Pump Chump!::
Joined
·
3,047 Posts

·
Registered
Joined
·
433 Posts
Discussion Starter · #11 ·

·
Registered
Joined
·
433 Posts
Discussion Starter · #12 ·
Ok got the pics prob is they are on my phone and i can't post um can i send um to one of you guys to post them of yours plz mines a dumb phone
 

·
Registered
Joined
·
433 Posts
Discussion Starter · #13 ·
Anyone????
 

·
Registered
Joined
·
433 Posts
Discussion Starter · #15 ·
ahh hold on ill go snap some with a cam, cant figure out how to get my phone to send to emails
lol
 

·
Registered
Joined
·
433 Posts
Discussion Starter · #17 ·
o lol what eve i got cam pics that are better anyway thanks tho
 

·
Registered
Joined
·
433 Posts
Discussion Starter · #18 ·
pics

So as you can see the stem and stop seems to be good, yet it still does it. Mop n glo on plastics after a ride looks pretty good, also threw in so pics of the warrior the kx80 and my dad's magna :D
P1030923.jpg

P1030925.jpg

P1030929.jpg

P1030930.jpg

P1030932.jpg

P1030933.jpg

P1030936.jpg

P1030937.jpg

P1030938.jpg

P1030941.jpg
 

·
Registered
Joined
·
1 Posts
I had a simular problem on a raptor once and it turned out the tie end arm nuts came loose and after some adjustment it fixed it.
 

·
Registered
Joined
·
433 Posts
Discussion Starter · #20 ·
hmm ill play around with it some more before cross country practice tomorrow
 
1 - 20 of 20 Posts
Top