Suzuki Central Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
724 Posts
Discussion Starter #1
This is going to be hard to explain. I am installing a RM Killswitch on my 04 KFX. Most of the previous threads deal with 03's which seem to have some different wire colors. The wiring diagram that Rstaw put up is pretty accurate it is in the maintenance section. I have connected my oranges to my orange and white...and connected those to a wire on the new killswitch. Then this is where I am getting into problems...of course I am replacing the clutch perch(bypassing clutch sensor). When the wires leave the clutch perch they go into a connection(as discussed in Normal's instruction thread). The wires in that connection are the yellow/black and black. After the connection the black jumpers into the blob and the other wire is black with white(I'm assuming its supposed to be y/b) stripe goes into harness(I'm thinking it splices with the yellow/black). I figured I would cut after both connectors (the south side of the connection)solder them together and run the black wire to the yellow and black wire and connect it to the other wire on the kill switch the complete the circuit. When I did that the quad turns on when I turn the key , then I hit the kill switch to see what happens and it blows a fuse by the battery(I think its by the starter relay). Also in the wiring Diagram its a bit confusing. It just shows the yellow/black wire going to the clutch sensor back to the starter and thats it. When it actually goes to the black blob also. Any advice or ideas or laughs at me would be appreciated. Thanks, Jason
 
1 - 5 of 5 Posts
Top