Suzuki Central Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
254 Posts
Discussion Starter #1
has anyone had a problem with their parking brake going out? i tried to engage mine yesterday on a ride and it didnt work and has not worked since. kinda sh1tty since i found this out on a hill!
thanks
 

·
Registered
Joined
·
49 Posts
hey,
do you by any chance have a picture of your Z?? i was checking your sig and i saw that u have the alba kit?? i was thinking of getting it?? easy to install and look good?? i just ordered a FMF Titanium 4 Exhaust and Maxxis Razr's. ok back to the topic yes my parking brake does work but not really well i can move it if i want to with the brake engaged.
:twisted: Corey :twisted:
 

·
Registered
Joined
·
379 Posts
Mine stopped working the other day too so it is going to go. Besides, the bars will look much cleaner with all of that junk gone.
 

·
Registered
Joined
·
254 Posts
Discussion Starter #4
i took mine in and they said it was just an adjusment to the cable...but i dunno...it seems to work fine now so we'll see........anyways i dont have the alba kit on yet..its ordered and im susposed to get it as soon as they recieve it, but im thinking about waiting because ceet makes the kits for alba and when i called them they said they were comming out with kits of their own within 6 weeks or so...im thinking about waiting to see what comes out.it kinda helps living mins away from both places (alba and the ceet factory) :wink:
 

·
Registered
Joined
·
582 Posts
Check the booklet that came with the Z, full details on how to adjust the parking brake twards the back of the book. Easy to adjust.
 
1 - 5 of 5 Posts
Top